La semana pasada os contábamos que el conocido hacker Pod2g estaba  bastante confuso acerca de qué hacer con el Jailbreak Untethered para iOS 5.1. El desarrollador francés ya ha encontrado cinco exploits (vulnerabilidades del sistema) que podrían ser aprovechados para la creación de un Jailbreak Untethered para la versión más actual de iOS.  Sin embargo dudaba entre sacar ya el Jailbreak Untethered o esperar a la llegada de iOS 6.

La versión iOS 6 será presentada, casi con toda seguridad, a mediados del próximo mes de junio con motivo del evento WWDC 2012 que Apple ha programado. Esta próxima entrega apunta a introducir muchas novedades pero también amenaza con ser todo un reto para los desarrolladores de Jailbreak. Si iOS 5 ya supuso meses de espera, no sería de extrañar que con iOS 6 la cosa se complique todavía más. Por este motivo, si Pod2g se guarda los exploits que ha descubierto podría ser un proceso más sencillo.

Para salir de dudas, Pod2g propuso una encuesta para que los usuarios diesen su opinión a la pregunta “¿saco ya el Jailbreak o espero a que salga iOS 6?”. El plazo para responder termina en aproximadamente 20 horas y en estos momentos la opción ganadora es que comience a trabajar ya en el Jailbreak Untethered para iOS 5.1, con un 63% de los votos. Ya han votado más de 150.000 personas y teniendo en cuenta que queda muy poco tiempo, es de suponer que el resultado se mantendrá así.

Pero Pod2g no ha dejado de trabajar pese a estar a la espera de una respuesta por parte de sus seguidores, más bien todo lo contrario. El desarrollador ha anunciado en Twitter que el pasado fin de semana ha sido muy productivo ya que ha encontrado dos nuevos exploits. Además se trata de dos exploits cruciales para la creación del Jailbreak. Por un lado ha conseguido un exploit de kernel -que sirve para “inyectar” el Jailbreak- y otro a nivel de root land -raíz del sistema-. Con esto ya tendría siete exploits en su poder que seguramente terminarán en un Jailbreak para iOS 5.1.

Lo cierto es que si Pod2g se guarda los exploits para iOS 6, Apple podría haber hecho modificaciones en el sistema y que éstos quedaran inservibles. Su amigo y también hacker Chpwn le recomienda que se ponga a trabajar en el Jailbreak Untethered para la versión actual porque lo de guardar exploits no ha funcionado en el pasado. Esto coincide con la opinión de la mayoría de los usuarios, al menos de todos aquellos que han actualizado a iOS 5.1 y no pueden aplicar el Jailbreak Untethered a sus dispositivos.

Hasta el momento, el desarrollador no ha hecho referencia a los dispositivos que serán vulnerables a este Jailbreak Untethered aun en proceso. Si seguimos la lógica de ocasiones anteriores, primero llegará para los terminales con procesador A4 o anterior (iPhone 4, iPhone 3GS, iPad 1, iPod Touch 3G-4G) y más tarde empezará a trabajar en el método de desbloqueo para los iPhone 4S, iPad 2 y el nuevo modelo de iPad. Estos últimos usuarios son los más perjudicados ya que hasta la fecha no hay forma de aplicarles el Jailbreak a sus dispositivos con iOS 5.1, ni siquiera en modo Tethered.

Recibe nuestras noticias

De lunes a viernes mandamos un newsletter con los titulares del día

I will never give away, trade or sell your email address. You can unsubscribe at any time.

Otras noticias sobre... ,