Menos de 24 horas, eso es lo que han tardado los desarrolladores de Jailbreak en publicar la versión de este proceso para dispositivos Apple con la nueva entrega del sistema operativo iOS 5.1. Desde ayer por la tarde ya es posible actualizar los iPhone, iPad y iPod Touch a esta versión, que vino de la mano del nuevo modelo de iPad. Ya advertimos que iOS 5.1 elimina la vulnerabilidad que hizo posible el último Jailbreak Untethered, por tanto todos los usarios que hayan aplicado el Jailbreak o deseen hacerlo no deben instalar esta versión si no quieren perder el Jailbreak.

El iPhone Dev Team ha anunciado en su página web oficial que los usuarios que hayan actualizado por accidente a iOS 5.1 podrán desbloquear sus terminales con este método, pero cuidado porque hay una serie de condiciones. Para empezar sólo los propietarios de un iPhone 4, iPhone 3GS, iPad 1 o iPod Touch (de tercera y cuarta generación) podrán aplicarlo. Esto deja fuera a todos los dispositivos con procesador Apple A5, o lo que es lo mismo, los iPad 2 y iPhone 4S (también se incluye el nuevo iPad de tercera generación).


Además estamos hablando de un Jailbreak Tethered, este método no es completamente estable y lo mejor es esperar a que aparezca el Jailbreak Untethered (sin ataduras). Si el Jailbreak es Tethered tu dispositivo no podrá reiniciarse de forma autónoma, es decir, que tendrás que conectarlo al ordenador y reiniciarlo usando la opción “Just Boot” del programa Redsn0w (la aplicación que se usa para llevar a cabo el proceso de Jailbreak o desbloqueo). No hace falta decir lo engorroso que puede llegar a ser si apagas el terminal y no tienes acceso a un ordenador. Sin embargo existe una opción intermedia que mejora esta situación. Se trata del parche SemiTether disponible en Cydia y que hará que el terminal se pueda encender sin pasar por Redsn0w, aunque algunas funciones no estarán operativas.


Hay una forma de recuperar tu Jailbreak Untethered si has actualizado a iOS 5.1 por error, y es volver a la versión anterior de software (iOS 5.0.1) mediante las  herramientas disponibles para esta tarea como TinyUmbrella o iFaith, aunque sólo será posible si previamente has guardado los SHSH Blobs -estos archivos son imprescindibles para poder hacer downgrade (bajar de versión), si no los has guardado no habrá vuelta atrás-. Una vez más, los usuarios de iPhone 4S o iPad 2 no podrán hacer uso de este método.

Ya sabíamos que iOS 5.1 no es vulnerable al Jailbreak existente antes de su llegada, los desarrolladores comprobaron que el exploit descubierto por el hacker Pod2g había quedado solucionado con esta versión. Desde que llegó la primera versión de iOS 5 los hackers trabajaron duro para dar una forma de vencer las defensas del sistema, tras meses de larga espera por fin dieron con la solución. Ahora todo empieza de nuevo, es el cuento de nunca acabar.

Para terminar insistimos una vez más que si tienes el Jailbreak ya aplicado no debes actualizar, además iOS 5.1 no viene con tantas mejoras como para que sea una actualización imprescindible.

Recibe nuestras noticias

De lunes a viernes mandamos un newsletter con los titulares del día

I will never give away, trade or sell your email address. You can unsubscribe at any time.

Otras noticias sobre... ,